Knowledgebase:
Language problems in output, such as question marks
Posted by Yoni Davidson on 16 January 2018 01:29 PM

If the default versions of your operating system and Visual Studio are not English, the IncrediBuild console output may read out unrecognizable characters, such as question marks or may just output "undefined characters." 

 

IncrediBuild needs to write the output in English, this is due to Delphi limitations, so if there is no English language pack available, you will face this issue. 

 For Visual Studio 2012 and above, you may need to install the English language pack for Visual Studio. It doesn't necessarily need to be the default language, but it needs to be installed regardless. 

 For visual Studio 2010 and below, you can't just install the English language pack without completely uninstalling Visual Studio and reinstalling it with the English version. The workaround for this is to use the UseMSBuild option in the registry. 

This is located under: 

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Xoreax\IncrediBuild\Builder 

Or use the /UseMSbuild argument in your build command. 

 

MSBuild provides the output in English by default unlike Devenv, which uses a different setting which applies the language used for Visual Studio. 

Note:
To use the UseMSBuild setting, the "ForceEnglishMSBuildOutput" value in the registry should be set to 1 (default) 

 

(0 vote(s))
This article was helpful
This article was not helpful

Comments (0)
Post a new comment
 
 
Full Name:
Email:
Comments:
Help Desk Software by Kayako incredibuild.kayako.com